Investigating CDN Network routing in US West Coast
Incident Report for CacheFly
Resolved
All routing has been normalized globally.
Posted Jan 03, 2025 - 16:14 CST
Investigating
We are currently investigating this issue.
Posted Jan 03, 2025 - 14:38 CST