LON1 degraded performance
Incident Report for CacheFly
Resolved
This incident has been resolved.
Posted Jan 03, 2025 - 16:14 CST
Investigating
We are currently investigating this issue.
Posted Jan 03, 2025 - 15:01 CST
This incident affected: CDN Delivery - Europe (LON1).